Автор Тема: Проблема с формированием документов (Libre Office)  (Прочитано 201 раз)

Динар

  • Посвященный
  • **
  • Сообщений: 58
  • Благодарностей 1
Здравствуйте,

Обнаружил проблему: при попытке сформировать документ из "Форма связи" в LibreOffice Writer (Версия: 5.0.5.2) в форму не передаются значения параметров, т.е. в форме остаётся название тегов, как будто открыл шаблон на редактирование.
При этом если формировать документ из "Объекта", данные предаются и документ формируется.

Проект во вложении.

Кто-нибудь сталкивался с такой проблемой? Как её решить?

Динар

  • Посвященный
  • **
  • Сообщений: 58
  • Благодарностей 1
Есть временное решение: документ формируется корректно из "Форма связи" если перед его формированием LibreOffice Writer уже был запущен.

При этом при формировании из "Объекта" не важно был уже запущен LibreOffice  или нет.

d.nikolaev

  • Administrator
  • Подмастерье
  • ***
  • Сообщений: 127
  • Благодарностей 0
Корректно будет работать только с версией:
Open Office 4.0 и Libre Office 4.0
В более новых версия наблюдаются различные баги. В связи с этим рекомендую использовать:
Open Office 4.0  - http://sourceforge.net/projects/openofficeorg.mirror/files/4.0.0/binaries/ru/Apache_OpenOffice_4.0.0_Win_x86_install_ru.exe/download
Libre Office 4.0 - http://downloadarchive.documentfoundation.org/libreoffice/old/4.0.0.3/win/x86/

vladimir.runa

  • Главный модератор
  • Мастер
  • **
  • Сообщений: 341
  • Благодарностей 22
  • skype: vladimir.runa
Спасибо за информацию! Попробуем разобраться с причиной такого некорректного поведения в 5-ой версии LO.

 

Яндекс.Метрика